Ubuntu12.04下安装NS3.25

作者: bbsmax 发布时间: 2019-09-09 浏览: 151 次 编辑

实验室项目的需求,要使用到NS3做仿真,使用实验室的电脑,Ubuntu12.04,版本比较低,建议大家使用16.04,这样安装依赖文件时不会出现版本过低的问题  

  (没管最后也安装成功了)。下面就安装步骤和遇到的问题做一下记录:

  (其中有参考各位老师的博客,我会在相应地方注明来源) 

=====================================安装如下===================================

1、首先安装依赖文件,依赖文件比较多,耗时较长,大家可以写成shell脚本,并加入自动确认参数(-y),就可以做其他事情了

  1.1、依赖文件大家可以参考书本《NS3-网络模拟器基础与应用》P14中的依赖文件

  1.2、再一个参考就是官网https://www.nsnam.org/wiki/Installation#Operating_system_and_compiler_support

  1.3、还有其他老师博客中的安装方法

2、下载并安装NS3

  可以先在/home目录下创建一个文件夹     mkdir NS3(文件名大家自己取),之后的操作在这个文件夹及其子文件夹下即可。

  2.1、由于项目需要,我下载的是NS3.25版本       wget https://www.nsnam.org/release/ns-allinone-${NS3_VER}.tar.bz2  ,其他版本可以在NS3官网上找到  https://www.nsnam.org/

  2.2、对刚才下载的ns-allinone-3.25.tar.bz2压缩包进行解压    tar xvjf ns-allinone-3.25.tar.bz2   解压后进入ns-allinone-3.25目录,如下图

          

  2.3、进入ns-3.25目录

          

  2.4、下面进入编译安装阶段,有两种编译方法

  2.4.1、使用 build.py编译

    这种方法的使用前提是之前从来没有编译过NS3,这是第一次,可以使用这种方法,比较简单,推荐首次编译者使用

    只一条指令,时间会长一些,可能要十几或者几十分钟

    在类似于ns-allinone-3.25的目录下,执行指令          ./build.py --enable-examples --enable-tests

    编译成功显示如下,没有编译成功的不要紧,不影响结果,一般用不到,如果后面用到再添加也不迟,好了,看到这里,NS3就算编译成功了,别急,我们后面还得测试一下,看看是否真的安装成功了。

                            

  2.4.2、使用 waf 编译 

    很多的用户之前都编译过,那就得有 waf 进行编译了,别无他法。如果首次编译使用 waf 也是可以的啦。看心情。。。。

    如果想改变原先的NS3的配置环境,比如要添加模块,需要使用交互式的 waf 命令,进行重新配置和编译。

    注意:waf 命令是在ns-3.25目录下,而不是ns-allinone-3.25目录下(不同的下载方式目录可能不同, 但应该类似)

    下面使用 waf 重新配置和编译ns3系统

    1、清楚先前的配置编译        ./waf clean

    2、重新配置 ns3             ./waf -d optimized --enable-examples --enable-tests configure

    3、正式编译 ns3        ./waf

    如果编译成功的话,也会出现  2.4.1 中编译成功的结果,此处不再放图。。。。。。

3、测试

  编译安装完成后,我们可以测试一下NS3是否真的安装成功,NS3提供了测试脚本 test.py 和很多示例程序

  3.1、使用 test.py 测试

  在ns-3.25目录下,键入指令   ./test.py -c core

            

  最后一行显示测试的结果,总共测试和测试通过的测试脚本数目

  3.2、使用NS3提供的测试示例进行测试,在ns-3.25目录下,

  1、 ./waf -d debug --enable-examples --enable-tests configure

  2、 ./waf

  3、 sudo ./waf --run scratch-simulator

  会显示如下结果,最下一行输出scratch simulation,相当于我们写的第一道程序输出结果“ hello world!”  哈哈哈,可算是安装成功了么?还有。。。。。

            

4、安装eclipse,在eclipse中编译NS3

  这个看个人习惯,有些朋友不习惯使用Linux中的 vim等 编辑器,可以借助eclipse这种图形化界面的工具

   安装方法:首先正常安装eclipse,然后安装C/C++语言插件CDT

    1、sudo apt-get install eclipse

    2、sudo apt-get install eclipse-cdt

  相关的配置在《NS3-网络模拟器基础与应用》这本书的23页,不在详述。

    ==============================遇到的问题及解决方法==========================

1、版本问题

  1.1、Unable to locate package <package>

  在安装依赖文件时,gcc-3.4未找到等出现了几次这样的问题,Ubuntu版本问题,所以建议大家用Ubuntu16.04版本,

  我这边sudo apt-get update也不管用,sudo add-apt-repository也不行 不过好在对结果影响不大,最终还是安装成功了

  可以参考 https://askubuntu.com/questions/378558/unable-to-locate-package-while-trying-to-install-packages-with-apt

  1.2、会出现这么一段话(忘截图了)       

  Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation

  也是版本太低了

  参考博客:https://blog.csdn.net/DelphiNew/article/details/5871425

2、waf died,not run test问题

  运行测试例 test.py 时,出现waf died,not run test

  解决方法:./waf configure --enable-tests --enable-modules = wimax,applications --enable-examples

       然后是:./waf 和 ./test.py

  参考:https://groups.google.com/forum/#!topic/ns-3-users/8J8ZuP1Ba0g

3、permission denied 问题

  在终端运行Python脚本出现permission denied 时,表示权限不够,提示那个权限不够就多这个文件修改权限

  1、修改当前目录的权限: sudo chmod 777 文件名

  2、修改当前目录及其子目录的权限: sudo  -R chmod 777 文件名

  参考博客:https://blog.csdn.net/sinat_33363493/article/details/52734746