webstorm不能识别一些js方法,如require

作者: web 发布时间: 2018-06-12 浏览: 501 次

直接上图吧

这里写图片描述

js运行不会报错,但webstorm却不认识这个方法,怎么办呢?

添加个支持就好了

还是直接上图吧

这里写图片描述

ECMAScript中几乎包含了当前所有开源js的源码支持。

我这边需要的是nodejs的require方法。

这里写图片描述

上面实际上我已经下载了Nodejs,我把他删除了重新下载。

下载好之后

这里写图片描述

require方法就可以识别啦,还可以直接看源码。

其他的一些方法支持也是同理的。